Help wanted: In-App Purchase

Hi,

We have an application where someone has tried to implement in-app purchase using the following plugin: @ionic-native/in-app-purchase-2

We have an issue where products seem to be getting approved before even calling store.order(‘product’).

It is written in react with mostly functional components using the following dependencies:
@bambora/checkout-sdk-web”: “^3.0.2”,
@capacitor-community/apple-sign-in”: “0.2.0”,
@capacitor-community/stripe”: “^1.1.0”,
@capacitor/android”: “^2.0.1”,
@capacitor/core”: “2.4.0”,
@capacitor/ios”: “2.4.0”,
@codetrix-studio/capacitor-google-auth”: “2.1.3”,
@ionic-native/core”: “^5.36.0”,
@ionic-native/in-app-purchase-2”: “^5.36.0”,
@ionic/cli”: “^6.11.0”,
@stripe/react-stripe-js”: “^1.4.1”,
@stripe/stripe-js”: “^1.15.0”,
@types/jest”: “24.0.23”,
@types/node”: “12.12.9”,
@types/react”: “16.9.11”,
@types/react-dom”: “16.9.4”,
@types/react-redux”: “^7.1.7”,
“classnames”: “^2.2.6”,
“cordova-plugin-purchase”: “^10.5.3”,
“final-form”: “4.18.6”,
“he”: “^1.2.0”,
“immer”: “^6.0.1”,
“native-run”: “^1.0.0”,
“node-sass”: “^4.14.1”,
“query-string”: “^6.11.1”,
“react”: “16.12.0”,
“react-aria-modal”: “4.0.0”,
“react-dom”: “16.12.0”,
“react-final-form”: “6.3.3”,
“react-google-login”: “^5.2.2”,
“react-gtm-module”: “2.0.8”,
“react-helmet”: “^5.2.1”,
“react-id-swiper”: “2.4.0”,
“react-redux”: “^7.2.0”,
“react-router-dom”: “5.1.2”,
“react-scripts”: “^3.4.3”,
“react-spring”: “^9.0.0-canary.808.8.4a87fcb”,
“redux”: “^4.0.5”,
“redux-devtools-extension”: “^2.13.8”,
“redux-thunk”: “^2.3.0”,
“swiper”: “5.2.1”,
“typescript”: “^3.8.3”,
“webfontloader”: “1.6.28”,
“whatwg-fetch”: “3.0.0”

If anyone has experience with implementing in-app-purchase-2 with react and functional components I would love to hear from you.

Please contact me here: erlend.aksnes@webstep.no

Hello @erlend-a

Sent you Email , Please check .

Regards
Ron

Hello

I can assist you with your requirement.
sent you a mail please check

Thanks
Olivia