Git error while adding android platform in windows

getting below error while adding platforms.

npm WARN deprecated @angular/http@5.2.10: Package no longer supported. Use @angular/common instead, see
    https://angular.io/guide/deprecations#angularhttp
    npm WARN deprecated cordova-plugin-console@1.1.0: This plugin has been deprecated since it is now included in
    the latest versions of cordova-ios
    npm WARN deprecated cordova-plugin-file-transfer@1.6.3: This plugin has been deprecated
    npm WARN deprecated sw-toolbox@3.6.0: Please migrate to Workbox:
    https://developers.google.com/web/tools/workbox/guides/migrations/migrate-from-sw
    npm WARN deprecated chokidar@1.7.0: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less
    dependencies.
    npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less
    dependencies.
    npm WARN deprecated rollup-plugin-commonjs@8.2.6: This package has been deprecated and is no longer maintained.
    Please use @rollup/plugin-commonjs.
    npm WARN deprecated rollup-plugin-node-resolve@3.0.0: This package has been deprecated and is no longer
    maintained. Please use @rollup/plugin-node-resolve.
    npm WARN deprecated request@2.88.2: request has been deprecated, see
    https://github.com/request/request/issues/3142
    npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries.
    Upgrade to fsevents 2.
    npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in
    other tools.
    npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
    npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
    npm ERR! code 1
    npm ERR! Command failed: C:\Users\ks1162\AppData\Local\Programs\Git\cmd\git.EXE submodule update -q --init
    --recursive
    npm ERR! C:/Users/ks1162/AppData/Local/Programs/Git/mingw64/libexec/git-core\git-submodule: line 7: basename:
    command not found
    npm ERR! C:/Users/ks1162/AppData/Local/Programs/Git/mingw64/libexec/git-core\git-submodule: line 7: sed: command
    not found
    npm ERR! C:/Users/ks1162/AppData/Local/Programs/Git/mingw64/libexec/git-core\git-submodule: line 22: .:
    git-sh-setup: file not found
    npm ERR!

    npm ERR! A complete log of this run can be found in:
    npm ERR!     C:\Users\ks1162\AppData\Roaming\npm-cache\_logs\2020-07-26T13_14_54_641Z-debug.log

anyone got this error?

If this is anything more than a toy project, I would strongly consider creating a brand-new project and parachuting the code into it. The dependencies are full of obsolete things.