FYI: Node 6.1.0 fails the tutorial. updating to 6.9.1 solved


#1

Time and again versions of node and npm play tricks :slight_smile:
Publishing just FYI, if someone searches for the latest info on what verifiably works :slight_smile:

Failed to “ionic serve” the tutorial project
ver => Microsoft Windows [Version 10.0.14393]
node --version => V6.1.0
npm --version => 3.8.9
npm install -g angular-cli@latest
npm list -g | grep angular => ±- angular-cli@1.0.0-beta.21
npm install -g cordova ionic
ionic start tut1 tutorial --v2
I got warnings
npm WARN prefer global node-gyp@3.4.0 should be installed with -g
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.15
Other than that - success
Cd tut1
Ionic serve
I got a blank page and javascript console errors:
Failed to load resource: net::ERR_ADDRESS_INVALID
\c:\Data\tut1\src\pages\hello-ionic\hello-ionic.ts:1 Uncaught Error: Module build failed: TypeError: Cannot read property ‘content’ of undefined(…)

As per subject installing the newest LTS version of node helped