File transfer plugin issue with crosswalk browser(android)


#1

i am testing my application in android… i am using file transfer plugin(org.apache.cordova.file-transfer) to download pdf files in my application. its working properly without crosswalk browser… after adding crosswalk browser, my application crashes , whenever file is downloading… without crosswalk browser, my application is very slow in android . please help to solve this problem.


#2

I’m facing a similar issue but my app crashes when I’m uploading a picture. Like mrsafi when I remove crosswalk it works fine but that is at a significant app performance cost. Help on this issue would be much appreciated.


#3

I have the same problem:

  • File Transfer plugin: crashes when downloding or uploading
  • File plugin: works fine
  • Camera plugin: works fine

I tried with crosswalk v10 , v11 and v12.
Devices: motorola razr i android 4.1.2 , samsung galaxy s2 android 4.1.2, asus transformer tf101 cyanogenmod android 4.2.2
I noticed that it works fine on the galaxy nexus cyanogenmod android 4.4.4, but we don’t need crosswalk for android 4.4

Is this an issue with ionic, crosswalk or filetransfer plugin ?!


#4

I did some digging and I found this: https://github.com/gaochun/cordova-plugin-file-transfer/commit/0063249e279b99a0feb4601650fc3a4c9e8a8ed2?diff=split It seems that the manner in which cookies are stored in crosswalk causes the error. I made the change, pushed it to my device and the upload worked.


#5

This also works for me
Thanks


#6

Thanks… This works for me too.


#7

Works for me as well… You saved my time. :smile:


#8

@jworm7 great fix!

(wish i would have found it hours ago)


#9

know what, here’s one better, an easier one for the rest of the world:

fixed the plugin, the repo is here:


#10

Thanks @mikem, installing the file-transfer plugin version you pointed solved the error.

I wonder if there is any solution that would cover both crosswalk and “clean” Ionic apps, so that it could be merged to the file-transfer official plugin.

Would it be possible to check if crosswalk is present or not and use the correspondig cookie manager?


#12

switching from org.apache.cordova.file-transfer to cordova-plugin-file-transfer worked for me. Note I also had to switch from org.apache.cordova.file to cordova-plugin-file

Apparently apache renamed all their cordova plugins: https://cordova.apache.org/announcements/2015/04/21/plugins-release-and-move-to-npm.html


#13

The problem was solved with the 1.2.0 release of the plugin on June 17th:


#14

Thanks @simplejoymedia Great FIx! Working fine for me :grinning: :blush: