Fatal: App doesn't exist or you do not have access to this repository


#1

Okay, so I have linked the project, setup the ssh key, checked that the ssh key is in my account settings, verified my ~/.ssh/config yet it’s still failing on git push ionic master

$ git push ionic master
fatal: App doesn't exist or you do not have access to this repository.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

The remote is definitely there, I’m quite familiar with ssh, git, etc. and I just cannot figure this out.

Perhaps it’s an issue with git config user.name and git config user.email, but I have made sure that the email matches the email for the account… I really am at a loss here…


#2

Same problem for me. Anyone figure out how to get through this issue? This worked for me with my personal email address. I’ve now set up a separate account for work and I’m not able to push to ionic master.


#3

Same problem here. Any solution?


#4

It seems that is only happening on OSX. I just tried on a Windows machine, and I did not get the problem.


#5

I experience the same trouble. I have Fedora Linux system. I have not Pro account but is a member of a Team.


#6

Windows client (git bash) - the same issue


#7

me too, linux client


#8

Hi everyone! I requested about the problem to the Ionic support. After some investigation the problem in my particular case was rather simple… The username of someone of the members of the team was exactly the same as a name of organization itself. Here is the citation:

Blockquote
It looks like somehow the other member of your org has the same username as your organization. The person with that username will be prompted to change their username the next time he logs in. Ask him to log out and log back in. He can use any valid username other than “orgaization-name” as that’s in use by your organization.
Once you’ve made the change you should be able to push to organization projects normally. The person mentioned may need to change his remotes for personal projects to match the pattern.
git @git.ionicjs.com:<username>/<app name>.git
Blockquote

Hope that can help to anyone else, cheers!


#9

It’s happening on windows machine as well , especially if you create a new app on ionic pro dashboard , the previously existing apps on ionic dashboard are working fine , (i.e clone , push etc all operations mostly working) but not on newly created apps.
New apps created on: 22 March 2018 (no git operation working on any machine)
So i believe this is an issue at ionic’s end.


#10

I upgraded from personal account to company, moved the app and now I get the same error. it shows me as linked, ssh etc is all correct, but when I try and push, “App doesn’t exist or you do not have access to this repository”

— any ideas?


#11

I think it’s a little late and I hope you found the solution, but I had the same problem and I solved it by doing an “ionic link” on the same project.
Selected Ionic Pro or Git as you want and pushed the whole thing