ESRI/ArcGIS Ionic 2


#1

Hi,

I’m wondering has anyone here ever tried to integrate the ArcGIS v3 API with an Ionic 2 application. I’ve been trying to follow an Angular 2 example (couldn’t find an Ionic 2 sample) and I’m getting this error on running:

cannot find module ‘esri-mods’

I’ve been trying to find a solution, but haven’t found one yet. Anyone ever encounter this?

Thanks,

Frank.


#2

Hey, I’m trying to get ArcGIS API for JavaScript 4.9 working with Ionic v3.

Did you have any success?

I’m stuck at a similar error: Error: Cannot find module "esri/map"


#3

Hey. The requirement was dropped so I never continued any further. Sorry - best of luck.