Errors creating app


I wonder if anyone can help me. I am trying to create my first app from the tutorial and I get one of the following two errors every time I try…

  1. shell.js: internal error
    Error: EPERM: operation not permitted, lstat ‘C:\Users<user>\myApp\node_modules.staging\ionic-angular-6c0b0195\es2015\util\debouncer.d.ts’ OR

  2. Error with start undefined
    Error Initializing app: There was an error with the spawned command: npminstall
    There was an error with the spawned command: npminstall

I always get one or other of the above messages but there appears to be no pattern as to which I receive i.e. I can get one 4 or 5 times then the other and vice-versa.

I have spent the last day or so Googling this and it seems a lot of other people have had similar issues but there appears to be no definitive answer as to why this is happening from my research. I’ve tried all the suggestions I can find but I still get the above errors.

Any help would be much appreciated.


If you don’t get any better answers, maybe look at nvm-windows.

Hi. Thanks for your reply. This is to enable a user to easily switch between versions of Node.js right? If so, I have tried a few versions already actually so I’m not sure this will help but I’m willing to give it a go. Which version should I be using? I currently have v6.10.1 installed.

I have seen some people suggesting I use the --verbose parameter and then check the npm-debug.log for more detailed information however when I tried this no such file was created so this didn’t help either.

Thanks in advance.

Update: I’ve now installed nvm-windows and updated node to v.7.8.0. The pertinent sections from the ionic info command are as follows:

Cordova CLI: 6.5.0
Ionic CLI Version: 2.2.2
Ionic App Lib Version: 2.2.1
OS: Windows 10
Node Version: v7.8.0

I’m now consistently getting the following error:

Error with start undefined
Error Initializing app: There was an error with the spawned command: npminstall
There was an error with the spawned command: npminstall

Though this doesn’t feel like progress really. I’ve Googled this error and it seems to be a very common problem. Selected suggested solutions include turning off anti-virus, uninstalling everything and re-installing everything, installing particular versions of one or more dependencies, the old tried and tested turning the computer on and off and lots more besides and a lot of it does sound like guessing at solutions really which isn’t ideal.

If anyone can point me in the right direction to resolve this issue then it’d much appreciated.


The reason I suggested nvm-windows (aside from general principle) is that your initial problem seemed to be related to filesystem permissions. Is that still the case?

Hi. Thanks for getting back to me. It’s much appreciated, I don’t think this is a permissions issue but just to be sure, this morning I uninstalled everything and then re-installed everything again as administrator and got exactly the same error.

I have since seen forum posts which have suggested that the order in which everything is installed has a bearing on this but I tried the suggested order and still I’m still getting the same error. I am going through all the suggestions I can find relating to this error at the moment but I’m pretty close to running out of options now and will be forced to give up and will have to look at alternatives. It’s disappointing to see from my research into this that many others have also given up and “gone elsewhere”.

The big problem here is that the exact same error seems to be being generated to cover a multitude of issues. It gives no clue as to what the problem is.

Well, after 3 days of messing around, installing and re-installing etc. I have now decided that I’m not going to get this working and I’m now looking at alternatives. I’ve now even seen some forum posts which suggest that certain operating system/processor combinations can result in ionic not working. It does sound like more guess work because it looks like nobody really knows all of the reasons why this error gets generated.

I may look into this again sometime in the future when it is more stable. Thanks rapropos for trying to help.