Error with Ionic serve without internet

Normally I use the command line ionic serve with no problems but today my internet connection was down and ionic serve reported the following :

throw er; // Unhandled ‘error’ event

Error: spawn “C:\Program Files\nodejs\node.exe” ENOENT
at notFoundError (C:\Users\John\AppData\Roaming\npm\node_modules\ionic\node_modules\cross-spawn\lib\enoent.js:11:11)
at verifyENOENT (C:\Users\John\AppData\Roaming\npm\node_modules\ionic\node_modules\cross-spawn\lib\enoent.js:46:16)
at ChildProcess.cp.emit (C:\Users\John\AppData\Roaming\npm\node_modules\ionic\node_modules\cross-spawn\lib\enoent.js:33:19)
at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)

When the internet came back on - no problem.

No internet or no network at all?

In case of no network at all, maybe you faced that error because of DevApp? No Wifi, no network, no way of spreading the app across the network…

The network was OK (home system) just no internet.

Oki doki, no idea then

I also had this error in december ( but not the same problem, I guess this stacktrace is like the overall try/catch displayed error when something not expected happens

If I disconnect the Ethernet cable then Ionic serve terminates after [OK] Development server running! message.

In that case, no cable, no network, no devapp deployment :wink:

When you do the same test but run ionic serve --local (no sure i think that’s maybe the argument) do you face the same error?

Same affect - without internet ionic serve stops working.

Weird, according doc (Error with Ionic serve without internet) --local should Disable external network usage

Would you like to try, just to make me happy :wink: , ionic serve --no-devapp

After that I will have definitly no more idea about that :smile:

Sorry still does not work - only different is that it reports the error with the enoent.js file.

The laptop still works without the internet - so guess I can live without it!

or maybe someone way more clever gonna find the solution, sorry that it didn’t worked out