Error while running meteor npm install --save

Hi I am working with meteor ionic2 and angular2 , I am getting error while running the command meteor npm install --save

npm WARN ionic-angular@2.0.0-beta.7 requires a peer of @angular/common@^2.0.0-rc
.1 but none was installed.
npm WARN ionic-angular@2.0.0-beta.7 requires a peer of @angular/compiler@^2.0.0-
rc.1 but none was installed.
npm WARN ionic-angular@2.0.0-beta.7 requires a peer of @angular/core@^2.0.0-rc.1
but none was installed.
npm WARN ionic-angular@2.0.0-beta.7 requires a peer of @angular/platform-browser
@^2.0.0-rc.1 but none was installed.
npm WARN ionic-angular@2.0.0-beta.7 requires a peer of @angular/platform-browser
-dynamic@^2.0.0-rc.1 but none was installed.
npm WARN ionic-angular@2.0.0-beta.7 requires a peer of @angular/http@^2.0.0-rc.1
but none was installed.
npm WARN ionic-angular@2.0.0-beta.7 requires a peer of @angular/router@^2.0.0-rc
.1 but none was installed.

How to solve this issue … and i don’t know where the issue is …

I never worked with meteor, but I believe the syntax for installing packages with npm is
npm install meteor -save

Thank you for the reply but that is the command for meteor cli