Error installing "cordova-plugin-file"


#1

Hi,

I was having error installing “cordova-plugin-file”.

Hope you can help me. Please see details below.


ANDROID_HOME=/Users/WebDevMac-2/Library/Android/sdk

JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_112.jdk/Contents/Home

Failed to install ‘cordova-plugin-compat’:Error
at Object.module.exports.check_gradle (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/lib/check_reqs.js:90:25)
at GradleBuilder.prepEnv (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/lib/builders/GradleBuilder.js:161:23)
at Api.module.exports.runClean (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/lib/build.js:131:20)
at /Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/Api.js:394:50
at _fulfilled (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:834:54)
at self.promiseDispatch.done (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:863:30)
at Promise.promise.promiseDispatch (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:796:13)
at /Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:604:44
at runSingle (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:137:13)
at flush (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:125:13)

Failed to install ‘cordova-plugin-file’:Error
at Object.module.exports.check_gradle (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/lib/check_reqs.js:90:25)
at GradleBuilder.prepEnv (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/lib/builders/GradleBuilder.js:161:23)
at Api.module.exports.runClean (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/lib/build.js:131:20)
at /Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/Api.js:394:50
at _fulfilled (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:834:54)
at self.promiseDispatch.done (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:863:30)
at Promise.promise.promiseDispatch (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:796:13)
at /Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:604:44
at runSingle (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:137:13)
at flush (/Users/WebDevMac-2/Documents/ionic/eMAH/platforms/android/cordova/node_modules/q/q.js:125:13)

Error: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.
Looked here: /Users/WebDevMac-2/Library/Android/sdk/tools/templates/gradle/wrapper