Error in plugin 'sass' (undefined)


#1

Hi, I have a problem when I try using Sass in Ionic.
I installed everything is required, gulp task starts, but when it compile ionic.app.css stops and give an error like:

ionic $ [10:05:35] Using gulpfile ~\Desktop\TIROCINIO\IONIC\rollPicker\rollPickerDemo\gulpfile.js
[10:05:35] Starting ‘sass’…
[10:05:35] Starting ‘watch’…
[10:05:35] Finished ‘watch’ after 16 ms
Error in plugin 'sass’
Message:
scss\ionic.app.scss
undefined
[10:05:35] Finished ‘sass’ after 66 ms

I figured out it’s guilt of @import “www/lib/ionic/scss/ionic”; row (cutting it out plugin works fine).
I noticed that extension missing and I change it to @import “www/lib/ionic/scss/ionic.scss”;
Same I’ve done with all internal files, which in @import were missing of _ (underscore) before name and extension (.scss).
I tried again launch my app but it doesn’t works, it keep to give the same error, even if after a bit more time, so I think issue is deeper.
Someone had the same problem or have an idea what could be the cause?

Thank you for attention, best regards.
N.


#2

Hello , i’m facing the same issue after running “ionic setup sass” or “ionic serve”, however i don’t think it’s related to the line : “@import “www/lib/ionic/scss/ionic.scss”;” .

This is my ionic info :

Your system information:

Cordova CLI: 5.4.1
Gulp version: CLI version 3.9.1
Gulp local: Local version 3.9.1
Ionic Version: 1.2.4
Ionic CLI Version: 1.7.11
Ionic App Lib Version: 0.6.5
OS: Windows 8.1
Node Version: v4.2.1

Hope someone will be able to fix this problem.

Thanks.


#3

I fixed the problem by deleting special charachters and spaces from my project name and running :

npm install node-sass@2
npm -g install node-gyp@3
npm rebuild node-sass

Not sure which one was the cause of the problem.Hope it will help someone.