Error: exporting my App from Creator


#1

Hello,

I’m trying to export the app from Creator following the steps of the documentation about “How to export a native Apk for Android and iOs”

I’ve done everything well but when I want to dowload the package clicking Package Project an error appear.

“There was an error with your build”

Does anyone knows why it appens and how can I solve this problem.
I really need the apk as soon as possible, so there is another way to get it?

There is a screenshot of the problem.


#2

You will probably have to use this to get to someone that can help: http://ionicframework.com/support#support


#3

I send a ticket 4 days ago and got no answer.

You know if dowloading the .zip project I can make the apk file?

I really need it for the next Monday and support isn’t giving me an answer.

Thank you Sujan.


#4

Unfortunately I have no idea how Ionic Creator works, and there is not much activity of Creator users here either.
With the .zip you could probably extract the project and build using Ionic CLI. But no details on this as well.


#5

I though that at the beggining,

I’ve create a new project with ionic CLI and change the content of the www folder for the unziped content of creator but it doesn’t work at all. When I have that i don’t know how to create the apk file.

Let’s see if someone could help. Thanks for everything.


#6

How did you create your Ionic project? You have to make sure it is a “Ionic v1” project.
What version of the CLI did you install and how?


#7

I’ve followed the documentation of Zip Export to Ionic Project

First npm install -g ionic@latest
Then ionic start myapp --type ionic1

Then I change the scss directory and the www folder for the files of my unziped project from creator.

At the 4 step npm install inside the project directory and appear this message. I don’t know if it all is OK:

C:\Users\Administrador\FMCanovelles2017>npm install
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\ch
okidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
1.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm WARN FMCanovelles2017@0.0.1 No repository field.
npm WARN FMCanovelles2017@0.0.1 No license field.

Finally, in the ionic.config.json file, add the JavaScript property “gulpStartupTasks”: [“sass”, “watch”].

When i run ionic serve i can preview my application.

I’m now trying to get the apk from that project but the command "ionic platform add --android " seems not to be working and i’m stuck.

I’m doing it well?


#8

You are missing a cordova there for current CLI:
ionic cordova platform add android

Then use ionic cordova run android.


#9

I already had the cordova added, and when i run ionic cordova run android it appears

BUILD SUCCESSFUL

Total time: 2 mins 2.535 secs

Built the following apk(s):
** C:/Users/Administrador/FMCanovelles2017/platforms/android/build/outputs/**
apk/android-debug.apk

ANDROID_HOME=C:\Users\Administrador\AppData\Local\Android\sdk
JAVA_HOME=C:\Program Files\java\jdk1.8.0_131
No target specified and no devices found, deploying to emulator

Error: No emulator images (avds) found.
1. Download desired System Image by running: "C:\Users\Administrador\AppData\Loc
al\Android\sdk\tools\android.bat" sdk
2. Create an AVD by running: "C:\Users\Administrador\AppData\Local\Android\sdk\t
ools\android.bat" avd
HINT: For a faster emulator, use an Intel System Image and install the HAXM devi
ce driver

[ERROR] Cordova encountered an error.
** You may get more insight by running the Cordova command above directly.**

[ERROR] An error occurred while running cordova run android (exit code 1).

Up to date I’ve been able to create an android-release-unsigned.apk file following the steps on generate apk but when I install it on my device it says "App not instaled"

I may done something wrong?

**EDIT:

Now running the ionic cordova run android. i have created a android-debug.apk and i’ve installed in succesfully on my device and it seems to work perfecly.**

I supose that it is a debug apk and i can’t upload it on google play or can I?

I’ve been following the steps but in the number 7: Align apk: zipalign -v 4 android-release-unsigned.apk appname.apk there is an error:

VERIFICATION FAILED

It is necesarry to do this step, or can I upload it without doing it?

I’m thiking the error could be about the pathing of the folder, but not sure at all.


#10

This is a necessary and essential step. You have to make it work.


#11

I’ve create a new project the same way I did the first time and following the same steps and it finally worked.

I’ve been able to generate de .apk file for release and upload it after some troubles. I will make a guide about what i’ve done, maybe someone could have the same problems i had.

Now let’s see if i can create

Thank you Sujan12 for your help and answering me those many times i have bother you . I really appreciate that man.