Error attaching iOS credentials to security profile [Ionic Push Beta]


#1

Hello!

I’m trying out Ionic Push now that the beta has been released. I’m in the process of trying to attach iOS credentials to my security profile (see docs).

When I run ionic security profiles list this is what I see:


stewart@sfml-stewart ~/Code/phone-signup $ ionic security profiles list

  name       │ tag        │ android │ ios 
─────────────┼────────────┼─────────┼────
  SoccerSubs │ soccersubs │ ✗       │ ✗   

So I know I still need to attach my iOS credentials for iOS.

When trying to attach my iOS credentials, this is the command I run:

stewart@sfml-stewart ~/Code/phone-signup $ ionic security credentials ios --profile 
SoccerSubs -c ~/Downloads/Certificate.p12 -p [my_certificate_password] -r 
~/Downloads/SoccerSubs.mobileprovision

And this is the error I get:

stream.js:94
      throw er; // Unhandled stream error in pipe.
            ^
Error: ENOENT, open '/Users/stewart/Downloads/Certificate.p12'
    at Error (native) 

I figured it might be a problem with file permissions, so I checked permissions on the .p12 file and saw this:

-rw-r--r--   1 stewart  36555137      3271 Mar  6 08:08 Certificates.p12

At first, I tried running ionic security credentials with sudo, and it did prompt me for a password, so I entered my system password, but then it just returned the same error. I tried running the command again with sudo, thinking that maybe I needed to enter the password for the .p12 file, but I never got the password prompt again.

So, I then tried to change the ownership of the file, running:

sudo chown -v root Certificates.p12 

And that resulted in ownership being transferred to root:

-rw-r--r--   1 root     36555137      3271 Mar  6 08:08 Certificates.p12

After that, I also changed file permissions for read/write/execute:

sudo chmod 755 Certificates.p12

And got this:

-rwxr-xr-x   1 root     36555137      3271 Mar  6 08:08 Certificates.p12

Anyway, none of the above ideas solved my problem and I’m not sure what to try next to get the iOS credentials properly attached to my security profile.

Thanks in advance for your help!