Empty array in emulator not with ionic serve

When I use ionic serve, chrome shows me the result I expected. But when I toggle the device mode it shows me nothing and it shows me nothing in an emulator either.

I firstly fetched some data with a http request and then splitted it inside a for loop. When I then tried to display the hole Array with {{underArray | json}} it shows me an empty array []. So I tried it again in the normal developer mode in chrome and everything worked fine. So I tried showing the fetched data from the http request with {{posts | json}} and it worked even in device mode. There are no errors at all since it works fine in with ionic serve.

My asumption now is that the loop takes to long and by that time the hole .html file is loaded. But probably thats not the case :slight_smile: Please help me out

Help us help you :grin:

We need to know more information. Can you provide a small demo? http://plnkr.co/edit/me3Uk0GKWVRhZWU0usad?p=preview

@mhartington It didnt worked on punklr. Maybe still the same issue maybe I am to stupid for doing it the correct way sorry. I just uploaded the app folder to GitHub here is the [link to GitHub repo] (https://github.com/Agoni1605/newsplusplusFeed/tree/dir)

Hopefully this shows the issue :smiley: