Embed external page in one of the slide


#1

How to insert/embed external web page in one of the slides.
Application have 3 slides , 2nd slide should be a web page. My Swipe left and right should switch the slides. Touch gestures are not expected to be handled with the embedded page.

Please refer to the below repository for details :

<ion-slide-box >
   <ion-slide>
      <div has-header="true" padding="true" style="width: auto; height: 400px; background-color:lightblue" >
        </br></br></br>
        Slide 1 {{navTitle}}
      </div>
    </ion-slide>
    <ion-slide>
      <div has-header="true" padding="true" style="width: auto; height: 400px; background-color:lightgreen" >
        </br></br></br>
        Slide 2 {{navTitle}}
        ***<object data=http://www.web-source.net width="600" height="400">
            <embed src=http://www.web-source.net width="600" height="400">    
            </embed>
            Error: Embedded data could not be displayed.
        </object>***
      </div>
    </ion-slide>
    <ion-slide>
      <div has-header="true" padding="true" style="width: auto; height: 400px; background-color:lightyellow" >
        </br></br></br>
        Slide 3 {{navTitle}}
      </div>
    </ion-slide>
</ion-slide-box>

#2

I loaded up your project and see the web page in the slide. It’s not pretty, but it’s there. What exact problem are you having?

As you can see from this screenshot, there are some security issues with loading your content. You’ll have to resolve those as well.


#3

I have two frames to be shown here, I could not see www.google.com.
I am testing the application using Phonegap/cordava and have configured it as access =* in config.xml but still not able to view it


#4

@Calendee , If you are not able to find the other frame with google.com, Could you try changing the url from w3schools.com to www.google.com.


#5

This problem is not specific to Ionic. It’s a general security issue. If you change the Google frame to :

<iframe src="http://www.google.com/&output=embed"></iframe>

You will see that the Google portion then loads with a 404.

You need to spend some time searching for solutions to “Display forbidden by X-Frame-Options”