Deprecated browserlist


#1
    Creating a new ionic project, an error occurred while running npm i command. I've got a warning indicating "deprecated browserlist@2.11.3 (3.0 config used in other tools)" and "hoek@2.16.3 (The major version is no longer supported)". I am using ionic 3.19.1.

I would like to know if updating to ionic 4.x is the only solution and, if so, what about the projects I created before with the 3.19 version? Are they going to work all right? How many changes should I make on them?
Thank you very much!


#2

It’s confusing, but Ionic doesn’t have a monolithic version number. At a minimum, you need to think of the CLI and the framework as totally disassociated. Theoretically (meaning “Ionic says this is supposed to work”), if you have created a project with version X of the CLI, then any CLI version >=X should be able to build it.

So, it sounds like you’re asking “can I upgrade the CLI without upgrading the framework in my old projects?”, and the answer is (supposed to be) “yes”.

Upgrading the framework is a completely different topic, and generally a lot more involved. In most cases, you are best off creating a new project from scratch and parachuting your old source into it.


#3
    Well, then. If upgrading is the only solution, I'll pray everything works fine in my previous projects. Thank you very much for your clear explanation.