ctorParameters.map is not a funcion

Hello, I wanted to use Network-information plugin and I had an old ionic-native version.
So I did:
npm rm --save ionic native
npm install --save ionic-native@latest
npm update

because Network-information plugin was changed in 2.2.12.

But now, when I do: ionic serve --watch the console throws: ctorParameters.map is not a function

My Ionic version is: 2.1.14

And my package.json:

{
  "name": "ionic-hello-world",
  "author": "Ionic Framework",
  "homepage": "http://ionicframework.com/",
  "private": true,
  "scripts": {
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  },
  "dependencies": {
    "@angular/common": "2.1.1",
    "@angular/compiler": "2.1.1",
    "@angular/compiler-cli": "2.1.1",
    "@angular/core": "2.1.1",
    "@angular/forms": "2.1.1",
    "@angular/http": "2.1.1",
    "@angular/platform-browser": "2.1.1",
    "@angular/platform-browser-dynamic": "2.1.1",
    "@angular/platform-server": "2.1.1",
    "@ionic/storage": "^1.1.6",
    "angular2-fullcalendar": "^1.1.1",
    "angularfire2": "^2.0.0-beta.6-preview",
    "firebase": "^3.6.4",
    "ionic-angular": "2.0.0-rc.3",
    "ionic-native": "^2.5.1",
    "ionicons": "3.0.0",
    "jquery-ui": "^1.12.1",
    "rxjs": "5.0.0-beta.12",
    "soundcloud": "^3.1.2",
    "zone.js": "0.6.26"
  },
  "devDependencies": {
    "@ionic/app-scripts": "0.0.45",
    "typescript": "2.0.6"
  },
  "cordovaPlugins": [
    "cordova-plugin-whitelist",
    "cordova-plugin-statusbar",
    "cordova-plugin-console",
    "cordova-plugin-device",
    "cordova-plugin-splashscreen",
    "ionic-plugin-keyboard"
  ],
  "cordovaPlatforms": [],
  "description": "Mindfulness: An Ionic project"
}

Any solution?

Thank’s so much in advance!


EDIT:

I’ve tried to update to rc4: (2.0.0-rc.4 (2016-12-15))

I used the updated guide and then, console throws me:

A recent change occured in ionic-app-scripts.
Please create a new file "main.ts" containing the content of "main.dev.ts", and then delete  the deprecated files.

So I searched it, and I found this issue
I did this steps, and then when I do: ionic serve --watch it build, but app is no loading and the browser console throws:

GET http://localhost:8100/build/main.css (index):33
GET http://localhost:8100/build/main.js (index):45
GET http://localhost:8100/build/main.js 404 (Not Found)(index):45 

Solved: https://github.com/driftyco/ionic/issues/10608