Cordova-plugin-locationservices - error


#1

When I do below commands:

- ionic start testApp blank -a "Test App" -i pl.foo.testapp
- ionic platform add android 
- ionic plugin add https://github.com/MobileChromeApps/google-play-services
- ionic plugin add https://github.com/louisbl/cordova-locationservices

I get error "Error during processing of action … "

What I do wrong? Early this case worked good.


Problem with google play services
#2

Unless someone here has direct experience with this particular issue : It does not have any relation to ionic itself…

you should file an issue with the plugin creator at https://github.com/louisbl/cordova-plugin-locationservices/issues

Maybe you’re going to have more luck there…


#3

Also this error is not related to ionic?


#4

No it’s not directly related to ionic, it’s reported by Cordova build process and it means that you did not install all the Android SDK parts you use.
Start the Android SDK manager and install all you find under Extras.


#5

Unfortunately, installing everything from Extras does not help me, still have the same error


#6

Are you sure your PATH and environment variables are correct?


#7

Do you mean the variables associated with the Android SDK Manager?


#8

PATH and ANDROID_HOME


#9

I have in variables:

  • ANDROID_HOME

    C:\Adt bundle\sdk

  • PATH

    C:\Adt bundle\sdk\platform-tools;
    C:\Adt bundle\sdk\tools;
    C:\Users\barto_000\AppData\Local\Android\android-sdk\tools;
    C:\Users\barto_000\AppData\Local\Android\android-sdk\platform-tools;
    C:\Users\barto_000\AppData\Local\Android\android-sdk\build-tools\20.0.0;
    %ANDROID_HOME%\tools;
    %ANDROID_HOME%\platform-tools;

Whether I miss something?


#10

I don’t think you are missing some, I rather think that you have too many of them.


#11

It turned out that I have two Android SDK Managers installed on my computer. I made the update in the “Extras” in the SDK that is not used by Ionic. After the update of SDK used by Ionic and after removing the plug-in which shares the Google Play Services, cordova-plugin-googleplayservices (recently it is not needed) the project began to build properly and works well now.

In addition I updated CLI Cordova to 5.1.1 version

gmarziou thanks for the help :smile: