Cordova Gigya SDK Integration on Ionic


#1

Hi Everyone,

I tried integrating Gigya SDK. I followed the correct documentation (http://developers.gigya.com/display/GD/Cordova). But I got an error when importing Gigya plugin itself via command-line.

Command-line for Gigya SDK Installation:
cordova plugin add https://github.com/gigya/cordova-plugin-gigya --save

Error:

Error: npm: Command failed with exit code 235 Error output:
npm ERR! addLocal Could not install /tmp/npm-7595-162de02d/git-cache-eb4b45ef/d78abeafef1608fd7491ed78af21ad0c2ca1fce8
npm ERR! Darwin 16.0.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "https://github.com/gigya/cordova-plugin-gigya" "--save"
npm ERR! node v6.11.0
npm ERR! npm  v3.10.10
npm ERR! code EISDIR
npm ERR! errno -21
npm ERR! syscall read

npm ERR! eisdir EISDIR: illegal operation on a directory, read
npm ERR! eisdir This is most likely not a problem with npm itself
npm ERR! eisdir and is related to npm not being able to find a package.json in
npm ERR! eisdir a package you are trying to install.

npm ERR! Please include the following file with any support request:

Has anyone tried integrating this SDK? Were you able to integrate it successfully? Did you encounter the same issue?

BTW here’s my config:

global packages:

    @ionic/cli-utils : 1.4.0
    Cordova CLI      : 7.0.1
    Ionic CLI        : 3.4.0

local packages:

    @ionic/app-scripts              : 1.3.12
    @ionic/cli-plugin-cordova       : 1.4.0
    @ionic/cli-plugin-ionic-angular : 1.3.1
    Cordova Platforms               : android 6.2.3
    Ionic Framework                 : ionic-angular 3.5.0

System:

    Node       : v6.11.0
    OS         : macOS Sierra
    Xcode      : Xcode 8.3.2 Build version 8E2002
    ios-deploy : not installed
    ios-sim    : not installed
    npm        : 3.10.10

Thanks!


#2

The plugin is missing a package.json file that is needed for Cordova 7.x.

Besides that something else seems to be broken, because with --no-fetch you should be able to install anyway. But I can’t find exactly out how.

In the docs is a step to download the plugin manually and then use plugman. Did you try that?