CodePush And Liverload


#1

Hi,

I have recently upgraded my project to the latest version(3.7.1), since the upgrade I cannot use “ionic cordova run ios -lc”, the app starts and hangs immediately.

I found out that when i uninstall Cordova codepush plugin everything works fine, installing it again kills livereload.

even with a blank project, as soon as you’ll install codePush plugin the livereload stop working for “ionic run”.
tried also to downgrade the plugin version with the same results.
anyone faced the same issue?
any workarounds for it?
10x


#2

Can you post a link to that plugin you are talking about? How did you implement it?

What is your ionic info output?


#3

Hi,

The link to the plugin is - https://github.com/Microsoft/cordova-plugin-code-push
And my ionic info output is:

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.13.1
ionic (Ionic CLI) : 3.13.2

global packages:

cordova (Cordova CLI) : 7.1.0

local packages:

@ionic/app-scripts : 3.0.0
Cordova Platforms  : ios 4.5.2
Ionic Framework    : ionic-angular 3.7.1

System:

ios-deploy : 1.9.2
ios-sim    : 5.0.13
Node       : v6.9.2
npm        : 5.5.1
OS         : macOS High Sierra
Xcode      : Xcode 9.0 Build version 9A235

Misc:

backend : legacy

#4

Can you define “hangs” a bit more?

Did you remote debug the problem on the device already? Follow these instructions here to debug the problem in Safari dev tools: https://ionic.zone/debug/remote-debug-your-app#ios Look at the console and network tabs for errors.


#5

I have tried to remote debug it, but the problem is that as soon as the build finishes, the splash screen is showing on the device for less than a second and the app quits.
It happens very quick and I cannot open the developer window in safari so quick…I don’t know of a way to open the console window before the app is running - safari suggesting my app under my device only after it starts.

It is very easy to duplicate this issue:

  1. Start a new blank ionic project
  2. Run it on a device with -livereload - works great.
  3. Run: ionic cordova plugin add cordova-plugin-code-push
  4. Try to run it on device with -livereload - not working. Run it without the livereload and it works.

Thanks,
Moshik