CLI throwing error on command creation


#1

I just updated the CLI this morning, and now when I create a project i get an error:

Creating Ionic app in folder /Users/ray/Dropbox/projects/crunchtime based on blank project

Downloading: https://github.com/driftyco/ionic-app-base/archive/master.zip
[=============================] 100% 0.0s

Downloading: https://github.com/driftyco/ionic-starter-blank/archive/master.zip

/Users/ray/npm/lib/node_modules/ionic/node_modules/progress/lib/node-progress.js:130
complete = Array(Math.round(width * ratio)).join(this.chars.complete);
^
RangeError: Invalid array length
at ProgressBar.render (/Users/ray/npm/lib/node_modules/ionic/node_modules/progress/lib/node-progress.js:130:14)
at ProgressBar.tick (/Users/ray/npm/lib/node_modules/ionic/node_modules/progress/lib/node-progress.js:86:8)
at IncomingMessage. (/Users/ray/npm/lib/node_modules/ionic/lib/ionic.js:546:13)
at IncomingMessage.EventEmitter.emit (events.js:117:20)
at IncomingMessage. (stream_readable.js:745:14)
at IncomingMessage.EventEmitter.emit (events.js:92:17)
at emitReadable
(_stream_readable.js:407:10)
at emitReadable (_stream_readable.js:403:5)
at readableAddChunk (_stream_readable.js:165:9)
at IncomingMessage.Readable.push (_stream_readable.js:127:10)

My version is 1.1.6.


#2

I ran the exact same command again (with a new folder), and it worked.


#3

Hey raymond, yeah I got this issue too.

I ran it by max and adam, it has to do with a network issue. For some reason, if there’s a network issue, this is the error message that gets thrown.

In the next version of the CLI, we will be including a error message so it won’t be so cryptic.


#4

Thank makes sense. Thanks for the update.