After checking the beta.11 release notes, I couldn’t help to feel that onDidDismiss feels like a horrible name for an API. Personally it feels like it does not follow any naming convention set by HTML, so I’m wondering the story about the naming.
What was wrong before with
onDismiss? While designing an API you can basically choose to represent 2 paths, either triggering events before they happen and allow preventing them, or after they happen and provide a separate event before things occur. Since
onDismiss was triggered the dismissal occurred, something like onBeforeDismiss would clearly indicate that a dismiss is planned and this is the time to stop it. The “Did” in the name seems redundant to me.