Capacitor Push Notifications - no sound (iOS)

We use the Capacitor Push Notifications plugin but when iOS users receive a notification there is no sound alert (on Android devices we do get the audible alert). Does anyone know why?

I have the following in my capacitor.config.json file (although the docs say this is only for when the app is in foreground, we need the audible alert to occur when the notification is received and the app is in background just like it does for Android)

"plugins": {
    "PushNotifications": {
      "presentationOptions": [

How are you sending the Push Notification?

@EinfachHans the back-end server sends the push notification as a Notification message - is that what you meant?

Can you try to add sound: "default" when sending the message?

@EinfachHans thanks, I can ask my back-end devs to try that - that doesn’t seem to appear here as an option (or am I missing something?) About FCM messages  |  Firebase

Are you sending via The FCM Rest Api directly or are you using a Library like firebase-admin - npm

Not sure - I would have to find out. I found this though - presumably this is the option you mean? php - FCM Android Notification sound issue - Stack Overflow

Yeah ask your Backend devs what you are using. But this option is available everywhere

1 Like

Great, thanks for your help!

JS SDK: Aps | Admin Node.js SDK  |  Firebase
PHP SDK: Cloud Messaging — Firebase Admin SDK for PHP Documentation
HTTP Rest Api: Firebase Cloud Messaging HTTP protocol