Can't run 'ionic start hello'


#1

Hi,

I’m just discover ionic and trying to give a try to make a app to learn.
I install node, cordova and ionic and run on terminal ‘ionic start hello’ and get this error message:

iMac-de-Pedro:~ pedroxxxxx$ ionic start hello
-bash: ionic: command not found

How can I fix it?
Thanks


#2

What version of node do you have? It should be using the latest, 0.10.26


#3

Hi mhartington!
Im using v0.10.27


#4

Ha, guess I’m a few version behind. You did sudo npm install... right? Try quitting your terminal and starting again. Sounds like a case of it not being available in you session.


#5

@mhartington,
I did sudo npm install -g ionic and than shows a lot of information of get and 304, but i did found a line with a error message when started the installation:

npm WARN package.json github-url-from-git@1.1.1 No repository field.

I already uninstall ionic and install again.

i also try sudo npm install -g gulp ionic with no success


#6

@mhartington i founded the solution, i read on stackoverflow that you have to create a path just by typing on terminal:

export PATH=$PATH:/usr/local/share/npm/bin

and than i install cordova and ionic :smile:
Thanks


#7

I had the same problem, no errors on installation but ionic command not found…I’ve tried your solution but nothing seems to change…
what can I do?

EDIT: resolved with export PATH=$PATH:/home/emanuele/npm/bin
…i don’t know why it was installed in home/USER


#8

@dededey :smile: I’m glad you solved by yourself