Can't deploy app for ios before 11.0

Hi Guys,
I’m having a stange error… I actually can’t publish my app on App Store for iphones having an older version than 11.0… I mean, when I target ios 11+, there is no problem, I can archive my version, but if I set it to 8.0 or 10.0, I get a strange error with CocoaPods.

Do you have any idea why it changes this way ?

Thanks