Cannot run my app on Android

#1

Hello guys, yesterday i tried to run my App using a Samsung Galaxy S3 (Android 4.3) but didn’t worked.
This screen showed up:


So, i made a blank project (using the blank template) and tried to run in the same Phone, the same error appeared.

Later that day, i tried to run using a Samsung Galaxy S7 Edge (Android 7.0) and worked.

What is happening? I have Android 4.3 installed in my SDK.

What i have to do to run my app using the Samsung S3?

Thanks :slight_smile:

#2

Android 4.2 and 4.3 are only semi supported by Cordova and Ionic as they don’t really offer the functionality needed. Users tned to install Crosswalk as a woraround for that.

1 Like
#3

Thanks for helping Sujan12, i appreciate your effort!

1 Like
#4

Lets us know if this fixed the issue.

1 Like
#5

I’m at the work now, as soon i get back home. I will try it! :grin: :+1:

1 Like
#6

Kinda worked, now the app runs, but 1 second after this error pops up.

First Image: Ionic Lab/iOS
Second Image: Samsung S3 Android 4.3 (at the Start)
Third Image: Samsung S3 Android 4.3 (1 second later)

#7

That’s a different error entirely. It looks like you’re trying to use an *ngFor with an object rather than an array.

To give more specific help though we’ll have to see your template and controller.

2 Likes
#8

i’ll provide the src asap! but how the hell the code runs on my pc ?

#9

Thanks for your time.

Isn’t a problem with my *ngFor.
I don’t know why, but the database that i was using to make all the operations, simply doesn’t work in that Samsung S3.
All Queries were returning Nulls (because all the insert process doesn’t work as well), thats why the ngFor isn’t working.

Thanks for everybody that helped me with this issue (the Crosswalk. Now the App really runs).
I’m switching to Firebase anyways, i can’t make a relational database work in my projects.

I appreciate all your Efforts <3

#10

If you don’t need remote storage, look into https://ionicframework.com/docs/storage/ Much simpler.