Cannot convert string value 'UNIFIED_TEST_PLATFORM'

Hello Everyone,
I am facing an issue after build ionic android app , can not open it on android studio ,
I installed JDK 10,11, 15, 20 tried to find solution but there is no , could you please help me,
I run these commands,
ionic build
ionic capacitor add android
ionic capacitor open android
and got this error ,

Thanks in advance for your support and efforts.

Hello.
Did you find a solution to the problem?

My google search tells that you have to update Android Studio.
Did you try that?

Yes,
AS -
as

Latest Android Studio is Android Studio Giraffe | 2022.3.1 Patch 1 from August 2023, Arctic Fox is from July 2021.
You are 6 versions behind.

Capacitor 5 requires Android Studio Flamingo | 2022.2.1 or newer.

oops
But when I try to “Check for updates” I see “No IDE or plugin updates available.”
How to update correctly?
Oh yes, I discovered that the latest update is not compatible with the Kotlin plugin and was ignored.
I will have to uninstall (update) Kotlin. What’s the best way to do this?

I would uninstall Android Studio and then download the latest version from Download Android Studio & App Tools - Android Developers

1 Like