Build Permissions - iOS Deployment

I have a question about distribution for iOS. I don’t know what the issue is and not sure if its something to do with my project setup. I have even rebuild my app and I am using the proper Apple developer credentials and have the proper permissions.

I had a version of the app that was rejected and I am trying to replace the app to test with Testflight. Whether I use App Store Connect, distribute or validate my app, I get this error:

I am very stuck on figuring out this issue. Any help would be appreciated. Thanks

It would appear the user you have logged into Xcode doesn’t have permission to upload the app to App Store Connect. I use a user with the Developer role.

My user has the admin and account holder roles. Everything worked great the first time but I am not sure why I can’t even validate the app now using the same account.

Have you tried removing and re-adding your account in Xcode?

1 Like

Yup. These are the steps I am taking.

  1. I run the app on my phone to test
  2. I do a build
  3. I create an archive
  4. In the archive window, I click validate
  5. I get the preparing screen in the archive window
  6. I select both ‘Uploads your app’s symbols’ and ‘manage version and build number’ then select next
  7. I Select Automatic Signing and next
  8. Everything is ready, I click validate
  9. I get that error, instantly

I am wondering if I should just recreate the project on the App Store Connect. (which would be time consuming)

I finally got it figured out. What a stupid issue. I removed my other developer accounts

Thank you for your time to help troubleshoot the problem.

1 Like