Build Native Versioning Not Working

When trying to restrict a Live Deploy to Native Android versions. It is not working.

See Video:

Does not save all values. Will only save Max value.

Hi edriven,

It looks like you are trying to add an equivalent version that is higher than the Maximum version, which is not allowed.

  • Minimum: Native binary must be at least this version in order to download this Live Update.
  • Maximum: Native binary must be this version or below in order to download this Live Update.
  • Equivalent: If the Native binary is this version, do NOT download this Live Update, because they are equal.

Try entering a valid equivalent version that is below the Maximum and let us know if you are still seeing this behavior.

Also, Appflow only expects app versions to follow the NPM semver standard. You can go through more examples on this here

Thanks!