Build fails on cloud (Ionic pro) but not on my local system


#1

I have just created an Ionic pro account and tried to upload my existing ionic app on my local to the cloud (Ionic pro git) but the build is failing every time (stacktrace attached below).

But the same app is working fine when I issue “ionic serve” command on my local.

Also, in the stacktrace, it is complaining for “HttpClient” not found. But I have commented that line and pushed it again. But still it is showing the same error. This is very strange (I am sure I am doing some silly mistake here). I am not sure if this issue is leading to a build failure or something else

Stacktrace:
Running with gitlab-ci-multi-runner 9.1.0 (0118d89)
on Prod Snapshot Builds 1 (c9648220)
Using Shell executor…
Running on ip-10-2-67-27…
Cloning repository…
Cloning into ‘/home/gitlab-runner/builds/c9648220/2/project-1’…
Checking out e8fda1a3 as master…
Skipping Git submodules setup
$ fetch-updates
Checking for build process updates…
$ build-app
Fetching build dependencies…
Running: npm install

node-sass@4.5.3 install /usr/src/app/node_modules/node-sass
node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v4.5.3/linux-x64-57_binding.node
Download complete
Binary saved to /usr/src/app/node_modules/node-sass/vendor/linux-x64-57/binding.node
Caching binary to /home/gitlab-runner/.npm/node-sass/4.5.3/linux-x64-57_binding.node

uglifyjs-webpack-plugin@0.4.6 postinstall /usr/src/app/node_modules/uglifyjs-webpack-plugin
node lib/post_install.js

node-sass@4.5.3 postinstall /usr/src/app/node_modules/node-sass
node scripts/build.js

Binary found at /usr/src/app/node_modules/node-sass/vendor/linux-x64-57/binding.node
Testing binary
Binary is fine
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

added 655 packages in 64.325s
npm install succeeded
Running: npm run build
npm info it worked if it ends with ok
npm info using npm@5.3.0
npm info using node@v8.2.1
npm info lifecycle TutorialIonicApp@0.0.1~prebuild: TutorialIonicApp@0.0.1
npm info lifecycle TutorialIonicApp@0.0.1~build: TutorialIonicApp@0.0.1

TutorialIonicApp@0.0.1 build /usr/src/app
ionic-app-scripts build

[19:44:35] ionic-app-scripts 3.1.2
[19:44:35] build dev started …
[19:44:35] clean started …
[19:44:35] clean finished in 1 ms
[19:44:35] copy started …
[19:44:35] deeplinks started …
[19:44:35] deeplinks finished in 143 ms
[19:44:35] transpile started …
[19:44:44] typescript: src/pages/item-details/motor.service.ts, line: 20
Cannot find name ‘HttpClient’.

  L19:  'Accept': application/json,
  L20:  'X-Authorization': this.AUTH_TYPE + this.AUTH_TOKEN

[19:44:44] ionic-app-script task: “build”
[19:44:44] Error: Failed to transpile program
Error: Failed to transpile program
at new BuildError (/usr/src/app/node_modules/@ionic/app-scripts/dist/util/errors.js:16:28)
at /usr/src/app/node_modules/@ionic/app-scripts/dist/transpile.js:159:20
at Promise ()
at transpileWorker (/usr/src/app/node_modules/@ionic/app-scripts/dist/transpile.js:107:12)
at Object.transpile (/usr/src/app/node_modules/@ionic/app-scripts/dist/transpile.js:64:12)
at /usr/src/app/node_modules/@ionic/app-scripts/dist/build.js:109:82
at
npm info lifecycle TutorialIonicApp@0.0.1~build: Failed to exec build script
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! TutorialIonicApp@0.0.1 build: ionic-app-scripts build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the TutorialIonicApp@0.0.1 build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/gitlab-runner/.npm/_logs/2017-11-20T19_44_44_874Z-debug.log
npm run build failed
Make sure your project has a build script in the package.json
Running after script…
$ clean-up
Cleaning up files…
Successful clean up
ERROR: Job failed: exit status 1


#2

Hi,
I have exactly the same problem.
Have you find a solution ?