Build failed - CompileC errors


#1

Not sure what I’m doing wrong. The repo has been working but then recently started failing. I think it must be something simple.

** BUILD FAILED **


The following build commands failed:
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/main.o MyApp/main.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/UIWebViewExtension.o MyApp/Plugins/com.ionic.keyboard/UIWebViewExtension.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/InAppPurchase.o MyApp/Plugins/cc.fovea.plugins.inapppurchase/InAppPurchase.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/SKProduct+LocalizedPrice.o MyApp/Plugins/cc.fovea.plugins.inapppurchase/SKProduct+LocalizedPrice.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/MainViewController.o MyApp/Classes/MainViewController.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/AppDelegate.o MyApp/Classes/AppDelegate.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/IonicKeyboard.o MyApp/Plugins/com.ionic.keyboard/IonicKeyboard.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
  CompileC build/MyApp.build/Debug-iphonesimulator/MyApp.build/Objects-normal/i386/CDVLogger.o MyApp/Plugins/org.apache.cordova.console/CDVLogger.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(8 failures)
Error: /Users/kirkstrobeck/git/tipfortip/ionic/platforms/ios/cordova/run: Command failed with exit code 65
    at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:135:23)
    at ChildProcess.EventEmitter.emit (events.js:98:17)
    at maybeClose (child_process.js:743:16)
    at Process.ChildProcess._handle.onexit (child_process.js:810:5)

#2

I turns out I have to prefix with sudo, but whay now?


#3

If you have to use sudo, maybe some permissions have changed in the project directory and your user doesn’t have read access to some files.


#4

Well above those lines there must be some errors regarding SharedPrecompiledHeaders

/var/folders/l9/dft31h9n7xn8qndqr1vcjrf40000gn/C/com.apple.DeveloperTools/6.0.1-6A317/Xcode/SharedPrecompiledHeaders/

something like this path… go to that folder (path may differ in your case) and delete all and build again… it should work…


Ionic build ios plugin errors (exit code 65)
#5

I found out what the issue is, but it shouldn’t be an issue. If I change even one character of the <name>Tip for Tip</name> field in config.xml it works. Like <name>Tip for Tipz</name>. I have no idea why this issue has started and no idea how to fix it. We aren’t renaming the app, so what’s my solution?


#6

This solution worked for me. Thanks a bunch!
I use Finder > Go to folder and typed in /var/folders and navigated there. I guess the same could be done using Terminal.


#7

Worked for me too, thx!


#8

Thanks runbrun! That fixed the issue for me too.