Build Error With --Prod

I am getting this error when i run build with --prod i have even tried to implement NO_ERROR_SCHEMA and also CUSTOM components in my @Ng Module but this error is not Bulging. any Help or suggestion would be appreciated Caio.


[23:02:04]  build prod started ...
[23:02:04]  clean started ...
[23:02:04]  clean finished in 10 ms
[23:02:04]  copy started ...
[23:02:04]  ngc started ...
Error: Template parse errors:
Can't bind to 'user' since it isn't a known property of 'avartar'. ("ANCED,... -
->
            <div class="cd-timeline-picture text-center dark">
              <avartar [ERROR ->][user]="fs.user"></avartar>
            </div>
            <!-- CUSTOMIZE YOUR STYLE USING DEFAULT IO"): ng:///C:/n/BibleIQ/src
/pages/forum/forum.html@20:23
'avartar' is not a known element:
1. If 'avartar' is an Angular component, then verify that it is part of this mod
ule.
2. To allow any element add 'NO_ERRORS_SCHEMA' to the '@NgModule.schemas' of thi
s component. ("CALM, BALANCED,... -->
            <div class="cd-timeline-picture text-center dark">
              [ERROR ->]<avartar [user]="fs.user"></avartar>
            </div>
            <!-- CUSTOMIZE YOUR STYLE USING D"): ng:///C:/n/BibleIQ/src/pages/fo
rum/forum.html@20:14
The pipe 'amTimeAgo' could not be found ("</span>
                <p class="marginTop5 cd-author mff">by {{fs.user.username}}</p>
                {{[ERROR ->]fs.dateCreated | amTimeAgo}}
              <ion-row>
            <ion-col>
"): ng:///C:/n/BibleIQ/src/pages/forum/forum.html@27:15
    at Error (native)
    at syntaxError (C:\n\BibleIQ\node_modules\@angular\compiler\bundles\compiler
.umd.js:1550:34)
    at TemplateParser.parse (C:\n\BibleIQ\node_modules\@angular\compiler\bundles
\compiler.umd.js:12041:19)
    at AotCompiler._compileComponent (C:\n\BibleIQ\node_modules\@angular\compile
r\bundles\compiler.umd.js:22867:39)
    at C:\n\BibleIQ\node_modules\@angular\compiler\bundles\compiler.umd.js:22764
:55
    at Array.forEach (native)
    at AotCompiler._compileSrcFile (C:\n\BibleIQ\node_modules\@angular\compiler\
bundles\compiler.umd.js:22748:20)
    at C:\n\BibleIQ\node_modules\@angular\compiler\bundles\compiler.umd.js:22725
:91
    at Array.map (native)
    at C:\n\BibleIQ\node_modules\@angular\compiler\bundles\compiler.umd.js:22725
:56
[23:02:12]  copy finished in 7.58 s

It seems like you should get that error, too, if you are not using --prod.
Please use ionic serve and open the console. Then navigate to the page where you are using:

<avartar [ERROR ->][user]="fs.user"></avartar>

You should see the same error in your console then. If you do, the error is in the way you use your custom component.

Thanks Hesters I don’t get the Error when i build Normally. But i have just Noticed that i was calling a component that i was not suppose to call on that page.
So i just Deleted the avatar component from that page and it Works Well now on --prod i am able to build.

Thanks All the same.