Build Android Error in Ionic on Mac Yosemite

I had cordova installed earlier and then started to install ionic following the steps detailed at . The build android option on my mac osx doesn’t work. The following errors appear. But these errors donot appear if I create a cordova application without ionic.

Try to remove and add again android platform. If it doesn’t work check android sdk version and jre version.

1 Like

remove will maybe not help, because you have problems with your access.

@fabioferrero I’ll try removing and installing ngcordova instead of the virgin cordova from apache that I have installed.
@kirrg In the SO question the guy has problems when using cordova. It works well in my system when I create a simple cordova app and build android. The error pops up whenever using ionic along with cordova. (PS: I’ve also tried cordova build in my ionic project the same error comes up)

but the error says “spawn access” and the hooks are form ionic.

can you please show me

ls -la hooks

lets check your permissions

@kirrg Here, Thanks for the efforts dude!


sorry forgot that there is a folder inside, i also need

ls -la hooks/after_prepare

Here you go!

ok here you can see -rw-r–r--
this means 644

try this
chmod 777 hooks/after_prepare/010…

I’m sorry I cant understand how to? just running this command generates this a no such file or directory error.

sorry i was too lazy to write the whole filename

chmod 777 hooks/after_prepare/010_add_platform_class.js

hope it helps. if not, tell us here


Thanks a lot @kirrg! Worked like a charm, in love with the ionic community already. :smile:

1 Like