Bug when run dexDebug, can't build Android apk!


#1

Hello,

When i buld for the first time $ ionic build android that’s works, but now never works… i don’t change anything. The error happen when the build is at “dexDebug”, this is a paste of my cmd.

Github gist

I’ve been installed Java Node Ant Android Studio SDK… That’s work on OSX, not on Windows :frowning:

Please help me…


#2

Please help… i can’t build app on windows…


#3

I think mainly to build android you need JRE and the android SDK that’s should be enough. I am built mainly on OSX but I think windows should work the same way.


#4

I have them :confused:

C:\ProgramData\Oracle\Java\javapath;C:\Users\Grégory\AppData\Roaming\npm;C:\User
s\Grégory\AppData\Local\Android\android-sdk\platform-tools;C:\Users\Grégory\AppD
ata\Local\Android\android-sdk\tools;C:\Program Files (x86)\Git\cmd;C:\Program Fi
les (x86)\Git;C:\Program Files\nodejs;C:\Users\Grégory\AppData\Local\Android\and
roid-sdk;C:\Users\Grégory\AppData\Local\Android\android-sdk\platforms;C:\Windows
\system32;C:\Windows;C:\Windows\System32\Wbem;C:\adb;C:\Program Files\nodejs\;C:
\Program Files (x86)\Git;C:\Program Files\nodejs;C:\Program Files (x86)\Android\
android-sdk;C:\Program Files (x86)\Android\android-sdk\platform-tools;C:\Program
 Files (x86)\Android\android-sdk\platforms;C:\Program Files (x86)\Android\androi
d-sdk\tools;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Users\Gré
gory\AppData\Roaming\npm;C:\ant\bin

#5

Temporary solution : new user without any accent (é - è…) so ionic reinstall gradle and its work


#6

Hey just wanted to let you know that you just saved my life by posting this.
When I was typing ionic build android, it was always stopping at dexDebug just like you. Then, I was having multiple errors saying ‘file not found’.

Indeed, my project was in a folder containing an accent.

Result : Putting it in a folder not having an accent solved my problem. :grinning:


#7

I’m happy that this post help you :smiley:
I’m going to post an issue on GitHub if you have the same problem :wink: