Beta 14 Ionicons using v.1.5?

I think Beta 14 is shipping with the previous version of Ionicons.

Just did a ionic lib update command and noticed v1.5 being used.

1 Like

I was about to ask the same question :wink:
Curious too

I found that:

=> available in the next release :wink:

Ah ok, I’ve re-upgraded it to v2 and all is well again…

Can you please detail the steps you took to upgrade the fonts?
I have been having some trouble updating the icons to V2

Went to

Downloaded the ZIP

Copied the fonts and the scss files across to the appropriate locations in my lib folder in www i.e.

www/lib/fonts and

I deleted the contents of the ionicons directory before pasting…

Executed gulp, should be sorted now. Just take care with ios7 and ios class name changes.

Thanks @gregorypratt for the steps, it really does help.

I have previously done exactly the same steps until the step where you execute gulp. Im very new to scss and so not sure how to go about doing it.

In the terminal (while in my project root directory) typed gulp

I then get the following errors:

 Error: Cannot find module 'gulp-util'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/ProjectDirectory/gulpfile.js:2:13)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)

Have you npm installed?

sudo npm i to install the required node packages

Then gulp

Sorry my mistake, I had to not previously done ionic setup sass

After doing that when I run gulp this is what i get:

[09:27:23] Using gulpfile ~/ProjectDirectory/gulpfile.js
[09:27:23] Starting 'sass'...

      throw er; // Unhandled stream error in pipe.
Error: EACCES, open '/Users/tanujd/ProjectDirectory/www/css/'

Similarly when I do ionic serve this is what i get:

[09:27:05] Using gulpfile ~/ProjectDirectory/gulpfile.js
[09:27:05] Starting 'sass'...
[09:27:05] Starting 'watch'...
[09:27:05] Finished 'watch' after 7.76 ms

      throw er; // Unhandled stream error in pipe.
Error: EACCES, open '/Users/tanujd/ProjectDirectory/www/css/'

Just a note, at this point the new font works, but no custom sass works

You’re getting a permission denied error. You need to run it as sudo.
sudo ionic setup sass

I have already done sudo ionic setup sass

After which when I would do ionic serve or even just gulp it would give me the error.

Just noticed that in the header of the “default starter projects” like “tabs” there is this:

<link href="lib/ionic/css/ionic.css" rel="stylesheet">

So even though I run gulp it doesn’t update the /lib/ionic/css file but it updates the www/css/

So if you are not using SASS, and want to update ionicons, make sure that the right .css file gets updated. You can change this:

<link href="lib/ionic/css/ionic.css" rel="stylesheet">

to this:

<link href="css/" rel="stylesheet">