App failed to run on Android Oreo


#1

Hi all.
My apps on Google Play failed to run after I upgraded my phone Android Oreo with the message - Application Error. The connection to the server was unsuccessful. (file:///android_asset/www/index.html) which appear after the splashscreen.
The apps were running fine before the upgrade.
Then, I tried creating a blank app with both android@6.4.0 and android@7.0.0. Both versions on device gave me the same error.

ionic info

@ionic/cli-utils  : 1.19.0
ionic (Ionic CLI) : 3.19.0

global packages:

cordova (Cordova CLI) : 8.0.0 

local packages:

@ionic/app-scripts : 3.1.6
Cordova Platforms  : android 6.4.0
Ionic Framework    : ionic-angular 3.9.2

System:

ios-deploy : 1.9.2 
Node       : v8.9.4
npm        : 4.0.5 
OS         : macOS High Sierra
Xcode      : Xcode 9.2 Build version 9C40b 

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : legacy

Anybody face the same issue?


#2

Turns out to be phone-related (Huawei Mate 8).
After enabled Settings - Developer options - Enable multiprocess Webview, all the apps are running without error.