App fades to black after first template loads


#1

just moved over to Xcode. Using ionic server my app comes to the login page just fine. But when I test on my iphone or the emulator, the splash screen shows and then the app fades to black. I saw a post from a few years ago and this seems similar, although I tried everything listed and am still stuck. Also, I tried to use WkWebView, and when I did that the app stopped after [TotalPluginStartup] . I have been working with ionic for awhile now, but it’s the first time I’ve gotten to the device testing phase and I’m not sure where to go from here.

Here’s my env:

Cordova: 6.4.0
ionic 2.1.18
Xcode 8.2.1
java 1.8.0_111

Console:
2017-01-15 16:44:59.150625 MyApp[2048:1167226] Apache Cordova native platform version 4.3.1 is starting.
2017-01-15 16:44:59.151275 MyApp[2048:1167226] Multi-tasking -> Device: YES, App: YES
2017-01-15 16:44:59.192991 MyApp[2048:1167226] Using UIWebView
2017-01-15 16:44:59.195599 MyApp[2048:1167226] [CDVTimer][handleopenurl] 0.063002ms
2017-01-15 16:44:59.197029 MyApp[2048:1167226] [CDVTimer][intentandnavigationfilter] 1.328051ms
2017-01-15 16:44:59.197139 MyApp[2048:1167226] [CDVTimer][gesturehandler] 0.055969ms
2017-01-15 16:44:59.218554 MyApp[2048:1167226] [CDVTimer][splashscreen] 21.344006ms
2017-01-15 16:44:59.225473 MyApp[2048:1167226] [CDVTimer][statusbar] 6.839991ms
2017-01-15 16:44:59.226298 MyApp[2048:1167226] [CDVTimer][keyboard] 0.735044ms
2017-01-15 16:44:59.226405 MyApp[2048:1167226] [CDVTimer][TotalPluginStartup] 30.864000ms
2017-01-15 16:44:59.432189 MyApp[2048:1167226] Resetting plugins due to page load.
2017-01-15 16:44:59.527423 MyApp[2048:1167226] Finished load of: file:///var/containers/Bundle/Application/53BDA2C0-99AD-41E8-ABC4-6479F96C519A/MyApp.app/www/templates/MySplash.html


#2

This looks like I’ve got issues with my routing