Any help on the White screen of death topic


#1

Just did a successful dev build, my app runs fine in creator without any errors, runs fine in the creator app on the devices, but when I install the build, installation is fine but when I open it on both iPhone and iPad mini, I see the splash screen but after that a white screen with my header color appears, Cannot for the life of me think what is wrong & do not know where to start. Does anyone know?


#2

Try the debug mode (you probably have I guess)

I’ve had it happen with a few different mistakes I’ve made, the last one that I can remember was having an image size on the opening screen as width 100% and the height was blank, fixed by putting height as 100%.

It’ll at least be one more thing to tick off as trying if it isn’t


#3

Did you remote debug the problem on the device already? Follow these instructions here to debug the problem in Safari dev tools: https://ionic.zone/debug/remote-debug-your-app#ios Look at the console and network tabs for errors.


#4

ionic cordova plugin add cordova-plugin-crosswalk-webview

try this command. it worked for me


#5

Hi, I tried to follow the link but got a bit lost https://docs.ionic.io/tools/developer/#safari-inspector .
My app is developed in Creator, which is ionic 1 and I see that this link is under ionic 2 is that my problem?
Where I get lost in the steps is on what device I need to do the steps in. Feel a bit stupid


#6

Wish it would have work for me tooo, but no luck, thanks


#7

OK found the missing links, the lights when on to debug remotely, my device should appear in safari on my mac under development,

I have an error:

XMLHttpRequest cannot load file:///var/containers/Bundle/Application/77060C61-E007-4835-BFB2-A25FB21E3C6C/VehicleLogBook%20NZ.app/www/templates/logbook.html. Cross origin requests are only supported for HTTP.

It has a problem with my html template?? Think it is a whole new topic or do you guys have any idea what my problem is? my previous builds did not complain about this…is this a support question?


#8

Are you doing anything special with this logbook.html?


#10

I build an HTML report which is just data that I format into HTML in my createHtml function and plug the result string htmlReport into the logbook.HTML by assigning the string to Ng-bind-html, it worked, the app is on the App Store released with this report. I turned my focus to my other app for a wee while and then when I returned to this app, rebuild It it failed tragically… all I did is cloned the project and redid the certificates so that all my apps certificates are valid, for my mac had hardware problems and had to be formatted,


#11

Then I would suggest you try to get some support:

http://ionicframework.com/support#support
(Scroll down to “Business and Customer Support”)


#12

Yes, l logged an issue with support because the errors are in the ionic framework

Kind Regards

Ilonka Buwalda
Director – EQUIAVIA Ltd.
m: +64 (0) 22 018 3043
e: ibuwalda@equiavia.com
www.equiavia.com