AngularJS adding Dependency issue


#1

I want to use angular-slider module in my project, I downloaded git from https://github.com/venturocket/angular-slider and added the angular-slider.js and angular-slider.css in my project and included the link in the index page like this

<link href="lib/ionic/css/ionic.css" rel="stylesheet">
<link href="css/style.css" rel="stylesheet">
<link href="../css/angular-slider.css" rel="stylesheet">
<script src="lib/ionic/js/ionic.bundle.js"></script> 
<script src="cordova.js"></script>
<script src="../js/angular-slider.js"></script>

and added the ‘uiSlider’ as dependency in app.js

var app = angular.module('app', ['uiSlider', ...]);

As soon as I add ‘uiSlider’ as dependency in app.js the app does not work. There are no error messages in the console. I tried adding another module in the same way but the same problem occurs.

Is there anything wrong with the way I am including the module in my project? Any help would be appreciated. Thanks in advance.


AngularJS Slider in ionic
#2

Not sure about angular-slider, but in general I prefer using Bower for adding dependencies.

I actually have a YouTube video showing how to do this: Ionic Framework: adding JavaScript modules


#3

Hey, I followed the tutorial video you suggested, but still the same issue


#4

Might be something specific to the angular-slider module then. That prajwalkman/angular-slider project actually says it’s deprecated and unmaintained.


#5

What does that slider do anyway? Isn’t it pretty much the same as a range field?


#6

Hello @Michael2 ,
The link of github you provided, this is deprecated I just check.
You can follow:

And another thing is that in app.js, I think you have to use like:
var app = angular.module(‘app’, [‘ui.slider’, …]);

You can try by that.


#7

@motiurion : I tried the module you suggested and various other modules but I am getting the same result. I guess the problem is not with the module.

For better clarity I have changed the link to the module and added a module that is not deprecated


#8

@encodedmirko : Its not module specific I tried other modules also and I need a dual knob slider for selecting a particular range.

For better clarity I have changed the link to the module and added a module that is not deprecated