Angular 17: DYLD error library not loaded @rpath/libswiftCore.dylib

After upgrading to Angular17 my builds fail to run on IOS devices. When the crash.log is opened in Xcode it shows the errormessage as in the topic title. The builds are from appflow.

If I build the same project from XCode itself and send it to appstoreconnect I have no problems.

This problem was caused by version 8 of cordova-plugin-firebase-analytics.
Reverting to 7.0.5 resolved it.

1 Like