Android Nor Ant Being Recognized From Terminal


#1

Hoping I can get a little help.

I have followed all the steps in the Windows setup tutorial mentioned on the Ionic Framework homepage and up until the presenter says to type “android” into the command prompt. When I try to run the command android, or ant -v, it is not being recognized.

Here is my PATH (C:\Users\coryldean\AppData\Roaming\npm; C:\xampp\AndroidSDK\sdk\platform-tools; C:\xampp\AndroidSDK\sdk\tools; C:\xampp\ApacheAnt\bin; C:\xampp\nodejs)

I have ensured java installed by running java -version in the command prompt and I get java version "1.8.0_20"
I have ensured node.js is installed by running node -v in the command prompt and I get v0.10.32

Neither ant -v or android is recognized.

Advice?

P.S. I restarted 3 times just in case. :slight_smile: and I posted this question on the youtube page and was responded to with the following, by the Ionic account: "Mention @mhartington, he’ll be able to help out "

Also, even though java is being recognized as it is, does it the java bin directory HAVE to be in PATH with the other directories?

Thanks in advance!


#2

Hey there, happy to see you got the youtube comment!

So android on windows setup is rough, so this is a common thing.

Just want to make sure that everything has been set up correctly, can you read over this post?

http://bealers.com/2014/06/phonegap-android-development-environment-for-windows/

A bit more in depth


#3

Well, I am following the instructions on the link you sent and the command prompt is still not recognizing ant or android commands.

I am able to run the Android SDK manager from the actual directory I installed it to. I even ran the Android SDK Manager and updated everything, but it’s still not recognized in the command prompt.

Again, here is the PATH variable. Maybe I am missing something?

C:\Users\coryldean\AppData\Roaming\npm; C:\xampp\AndroidSDK\sdk\platform-tools; C:\xampp\AndroidSDK\sdk\tools; C:\xampp\ApacheAnt\bin; C:\xampp\nodejs; C:\Program Files\Java\jdk1.8.0_20\bin


#4

Hmm then it has to do with the paths to the sdk

Try this

C:\xampp\AndroidSDK\sdk\platform-tools\; 

C:\xampp\AndroidSDK\sdk\tools\;