Android Error *Use of future reserved word in strict mode.*


#1

I am trying to run my application on my phone it gives me this error. What ive added recently with npm was this.

api-ai-javascript

In my Browser everything works fine.

My ionic info:
exe

My errorlog on phone:

Thanks for any help. :innocent:


#2

Hi @cherry! Did you manage to solve this issue?


#3

Sadly I didn’t found any 100% working solution. But what I found out is that I used some lines in the Code wich didn’t worked anymore in Ionic 3.

I didn’t proceeded to work on the problem yet since I am developing for iOS only atm. (I still got the iOS9 bug wich turned out to be a whitescreen now instead of blackscreen).

App runs smooth on iOS10. Maybe the Application would work if I would use a higher Android version.