Android breaks with es6


#1

Hey there, I’m trying to use es6 because I need Array.includes but I just can’t make it work with Android.

I get this error on my Android device (I’m using Ionic DevApp):

Does anyone have a clue on how to solve this?

$ ionic info

cli packages: (/Users/rafa/.nvm/versions/node/v8.7.0/lib/node_modules)

    @ionic/cli-utils  : 1.18.0
    ionic (Ionic CLI) : 3.18.0

global packages:

    cordova (Cordova CLI) : 7.1.0

local packages:

    @ionic/app-scripts : 3.1.2
    Cordova Platforms  : android 6.3.0 ios 4.5.3
    Ionic Framework    : ionic-angular 3.9.2

System:

    Android SDK Tools : 26.1.1
    ios-deploy        : 1.9.2
    Node              : v8.7.0
    npm               : 5.5.1
    OS                : macOS High Sierra
    Xcode             : Xcode 9.1 Build version 9B55

Environment Variables:

    ANDROID_HOME : /Users/rafa/Library/Android/sdk

Misc:

    backend : pro