A very weird problem

I am trying to run my project on ios with live reload…

using ionic run ios -device -l -c
produces the following error:

✗ ... Uhoh. Got error %s ... listen EACCES
 ✗ Error: listen EACCES
    at exports._errnoException (util.js:746:11)
    at Server._listen2 (net.js:1112:19)
    at listen (net.js:1155:10)
    at Server.listen (net.js:1240:5)
    at Server.listen (/usr/local/lib/node_modules/ionic/node_modules/tiny-lr-fork/lib/server.js:138:15)
    at Object.IonicTask.start (/usr/local/lib/node_modules/ionic/lib/ionic/serve.js:303:18)
    at /usr/local/lib/node_modules/ionic/lib/ionic/cordova.js:241:15
    at _fulfilled (/usr/local/lib/node_modules/ionic/node_modules/q/q.js:787:54)
    at self.promiseDispatch.done (/usr/local/lib/node_modules/ionic/node_modules/q/q.js:816:30)
    at Promise.promise.promiseDispatch (/usr/local/lib/node_modules/ionic/node_modules/q/q.js:749:13)
    at /usr/local/lib/node_modules/ionic/node_modules/q/q.js:557:44
    at flush (/usr/local/lib/node_modules/ionic/node_modules/q/q.js:108:17)
    at process._tickCallback (node.js:355:11)
    at Function.Module.runMain (module.js:503:11)
    at startup (node.js:129:16)
    at node.js:814:3

the app continues to compile and then launches on device but when I change any files I get this thing :

Unable to update live reload: { [Error: connect ECONNREFUSED]
  errno: 'ECONNREFUSED',
  syscall: 'connect' }

obviously this happened because I didn’t have enough access rights to run something so I decided to add sudo to the mix

so when I run sudo ionic run -device -l -c the compile process starts fine, the above error is not thrown anymore but then before deploying to the device the build fails and a different error is thrown saying:


The following build commands failed:
        Check dependencies
(1 failure)
Error code 65 for command: xcodebuild with args: -xcconfig,/Users/development/Desktop/instaplace/trunk/platforms/ios/cordova/build-debug.xcconfig,-project,Instaplace Cyprus.xcodeproj,ARCHS=armv7 armv7s arm64,-target,Instaplace Cyprus,-configuration,Debug,-sdk,iphoneos,build,VALID_ARCHS=armv7 armv7s arm64,CONFIGURATION_BUILD_DIR=/Users/development/Desktop/instaplace/trunk/platforms/ios/build/device,SHARED_PRECOMPS_DIR=/Users/development/Desktop/instaplace/trunk/platforms/ios/build/sharedpch
ERROR running one or more of the platforms: Error: /Users/development/Desktop/instaplace/trunk/platforms/ios/cordova/run: Command failed with exit code 2
You may not have the required environment or OS to run this project
cordova process is exiting

this is so weird…anyone else having this sort of problem?

The device flag is a cordova flag which is prefixed with 2 hyphens --device.

When I run livereload on my ios device I don’t use the device flag, so try running without the device option as well.

hey @djett, thanx so muck…this actually worked!
Running the command without --device always launches the app in the simulator for me.

1 Like